Heard about the Heartbleed vulnerability? Your hosted Vanilla Forum was not effected by it, so rest easy.
Service Status - Check out the Status Dashboard for service availability information.

Facebook photos are pixelated

jc_cameronjc_cameron Member
edited October 2012 in Questions
Hi,

When you connect via Facebook, the profile image that is grabbed and moved down to Vanilla is very low quality.

-jc


Comments

  • Hey @jc_cameron,
    We just changed the Upload Quality to 100 (default is 75). Let me know if that improves the quality of the images. *Note* This only effects images added from now on, not the ones that are already there.

    Thanks!
    Rasha
  • Hi Rasha, that does not address it. I just used the facebook connect to create a new account and it appears that you are using the Facebook image that is 50x50 and upscaling it to 250x250 in the profile. The image being used in my case is:

    http://graph.facebook.com/678368078/picture

    image

    which shows like:

    image

    in our vanilla hosted forums on the profile page.
  • By the way, I just took a quick peak at things regarding facebook connect profile pics. By no means is this definitive but you can get a 200x200 image by adding the parameter type=large at the end of the URL:

    http://graph.facebook.com/678368078/picture?type=large

    image
  • Any update on this? Hard to recommend using facebook connect if the photo that comes down looks so bad in your vanilla profile pic.
  • @jc_cameron We've committed a fix to our upstream code which will make it into the next release within a week or so. For the time being, I updated all your facebook users' images to reflect the larger version, and added a temporary patch to the facebook plugin that should cause it to automatically use that version from now on.
  • Thank you for the update. We will test it out.
  • Hi Tim (and rest of staff),

    Looks like the problem of pixelated facebook images has come back. The photo being pulled down is the 50x50 image again instead of the 200x200 photo that it can be.

    -jc
  • Hello JC,
    We'll look into that for you

    Thanks!
    Rasha
  • any word?
  • Hey JC,
    Nothing yet, we will definitely let you know when it has been fixed

    Thanks!
    Rasha
  • Hey JC,
    This should be fixed now!

    Thanks,
    Rasha
  • I just did a quick test - did not see any chance - the URL being called does not have the type=large parameter on it.
  • Where are you doing this test JC? I checked your DB and it looked like all the photos urls had "?type=large" on them.
  • Ok I see it now. Wow, I don't know how that's happening. Let me take another look at what code is currently running.
  • It looks good now JC, I've checked that new signups use the large image. Sorry for the confusion, there are 2 places where the image is set, and I'd only changed one of them.
This discussion has been closed.