Heard about the Heartbleed vulnerability? Your hosted Vanilla Forum was not affected by it, so rest easy.
Service Status - Check out the Status Dashboard for service availability information.

Does Vanilla support rich text or html formated emails?

Neil_LinkNeil_Link Member
edited January 2012 in Questions
I recently just signed up for the "Small Group" plan, and I noticed when Vanilla sends out notifications, it’s formatted in plain text. So you have to copy and paste the links. Is this suppose to be like this? If so, do any of the other plans support rich text or html emails?

Comments

  • Howdy Neil, what email service do you use? I've never had a plaintext link problem before.

    Email text changes are available on any plan, but changing formats may require a customization. I'll check and have a project manager contact you Monday if it does.
  • I use Outlook and our email system runs on an MS exchange internal server. I did test it via Gmail and everything looks fine, so it does look like its an issue specific to our system. I'm thinking it may have something to do with it thinking its some kind of spam, and is in turn disabling the links.
  • I've heard of that happening to others. I have very little experience with Outlook administration, but maybe you can add it to a list of trusted domains or senders and see if that corrects the problem.
  • So I had my IT guys look at it and they tried lots of things, but they still couldn't get it to work in the desktop Outlook client. It does however work on Outlook webmail. Here is what they said:

    We have tried to add to safe senders list and have adjust the macros and download trust settings to be completly open. No results.

    We have discovered that adding to safe senders list gives a temp fix to click on the link but unable to do so after moving off the email to a different one.

    Tried creating a rule to move it to another folder to see if that would enable the link. No results.

    Have discovered forwarding the email makes the link workable.

    Please check with Vanilla to see if any scripting can be changed to ensure that it is being sent in html format and not rich text.
  • LincolnLincoln Staff
    edited January 2012
    Hi Neil, I'm not sure if this is possible but I or another staff member will get back to you with an answer soon. I believe the current format should be plain text, not rich text, so we're relying on the fact that most clients will successfully parse a text link.
  • LincolnLincoln Staff
    edited February 2012
    Hi @Neil_Link, here's what I found.

    We can indeed set the MIME type to HTML for all outgoing emails from your site. The drawback to this is that none of the default messages are formatted for HTML, so line breaks disappear.

    I've just now set your outgoing MIME type to 'text/html' so you can test to see if this resolves your linking issue. We can also test a custom message if you're like to give us a new HTML-formatted message for one or more of the emails.

    If that works correctly, and assuming you want to restore line breaks in emails, you'd need to provide us HTML-formatted version of all email notifications. We can also do them for you, but that would likely entail an hour of billable time since it's a customization for your site.

    Let me know if this meets your need.

    Cheers
  • I just tested it, and it has fixed our hyperlinks issue! Thanks guys!

    The line break however have disappeared as you said they would.

    How much would it cost for an hour of billable time to get all of our emails formatted with line breaks again?

    Thanks again!
  • Hi Neil,

    I've followed up via email.
This discussion has been closed.