Service Status - Check out the Status Dashboard for service availability information.

Trouble activating blog comments

stevemcleodstevemcleod Member
edited April 2012 in Questions
I'm trying to add the new blog comments feature to my blog. But I can't get very far in the process of setting up Vanilla to do so.

On my dashboard I go to Forum -> Blog Comments: (

I see this:

"Vanilla can be used as a drop-in replacement for your blog's native commenting system. As a matter of fact, it can be used to add comments to any page on the web.In order for this to work, you will need to enable embedding.
Embedding is currently DISABLED."

I click on the "Enable Embedding" button.

I'm told "You must disable the "Embed Vanilla" plugin before continuing."

But I don't seem to have a way to disable it.


Steve McLeod
Founder, Poker Copilot


  • MarkMark Staff
    edited April 2012
    Hi Steve, you've got the old embed plugin turned on, which was used to embed your entire forum into a page of your website (the new method can do this, too). It can be enabled/disabled in the "addons" page of your forum's dashboard. There are full instructions on how to make the transition from the old way to the new way in the help on the top-right of the new embed page.
  • Hi Mark,

    Unfortunately step 1 of the full instructions doesn't match up with what I see in the dashboard:

    1. Copy the “Remote Url” field from your embed vanilla settings screen located in your forum’s dashboard under “Appearance” > “<Embed> Vanilla”.

    I have no "<Embed> Vanilla" under "Appearance" on the dashboard, as you can see in this screenshot:

  • LincolnLincoln Staff
    edited April 2012
    "<Embed Vanilla>" appears under "Addons" in the Dashboard. I've updated the article accordingly.
  • stevemcleodstevemcleod Member
    edited April 2012
    Hi Lincoln,

    The instructions say in step 1:
    Copy the “Remote Url” field from your embed vanilla settings screen located in your forum’s dashboard under “Addons” > “<Embed> Vanilla”.

    This still doesn't match up with what I see. Under Addons -> Embed Vanilla, there is no field labelled "Remote Url".

  • Hi Steve, this option doesn't appear for you because it was never set on your site. We've updated the instructions further to indicate you can safely skip this step. Sorry for the confusion!
  • Hi Lincoln,

    Thanks for your help. Now after trying this out, it seems I can't turn off the in-built comments system in, which I use for our blog,

    Looks like I won't be able to take advantage of Vanilla's innovative new feature.


    Steve McLeod
    Founder, Poker Copilot
  • I think you can disable blogger comments if you use blogger layouts.

    Blogger comment settings.

    In the coming weeks we'll come out with a specific widget for Blogger, but it will most likely require Blogger layouts.
  • Oh great, thanks Todd. I was using the new Blogger interface, which seems to lack this option (or my eyes simply scanned over it)

    Now when I get the universal code for Blog comments, I have to set a 'vanilla_identifier'

    var vanilla_identifier = 'your-content-identifier'; // Your unique identifier for the content being commented on

    Could you clarify: can I set this to any string of my choosing, such as, "poker-copilot-blog"?
  • You need to make sure that vanilla_identifier is different for each blog post. In blogger's case you can try using the url of the blog post if they give that to you somewhere.
  • Okay, I'm getting closer. I now have the "Leave a comment" text area appearing on each blog post. If I enter a comment it shows up on blog post's page.

    However there are two major problems:
    1) if i refresh the blog post page, the comment has vanished
    2) the comment doesn't appear in the vanilla discussion form.

    If you want to take a look at a sample blog post, you can try this:


    Steve McLeod
    Founder, Poker Copilot
  • Howdy @stevemcleod, it looks like the trouble is with your unique identifier. Can you just use the ID of the post rather than the full URL?

    We're going to work on making this more straight forward (so it won't care if you use the whole URL), but that's the short-term fix to make it work for you.
  • Blogger makes it tricky just to insert the id...I tried but it was getting way too complicated. However I found I can use the page title. Sometimes this may not be unique, as I may have multiple posts titled "Breaking News", but for my purposes I guess this will be good enough.

    Anyways, it is working, and for reference the code snippet enabling blog comments + forums is this:

    <b:if cond='data:blog.pageType == "item"'>
    <div id='vanilla-comments'/>

    <script type='text/javascript'>
    var vanilla_forum_url = '';
    var vanilla_identifier = '<data:blog.pageTitle/>';

    var vanilla_category_id = 'general'; // Create this discussion in a specific Vanilla CategoryID.

    (function() {
    var vanilla = document.createElement('script');
    vanilla.type = 'text/javascript';
    var timestamp = new Date().getTime();
    vanilla.src = vanilla_forum_url + '/js/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla);

  • Great, glad it's working
  • Oh dear, it is not working so well after all.

    Please look at this page:

    There are two problems:
    1) You'll see that each new comment on a specific blog entry results in a new discussion topic. I'd expect one discussion topic per blog post. So I've got five separate topics all for a blog post I wrote yesterday ("The Poker Copilot Blog: Update for Winamax Users")

    2) Some comments are coming up twice (and again, each with a new discussion topic).

    Any ideas? Do I need to change anything?


    Steve McLeod
    Founder, Poker Copilot
  • Just letting you know I've disabled vanilla forum blog comments from my blog. It seems this feature is not yet ready for use with


    Steve McLeod
    Founder, Poker Copilot
  • @stevemcleod I missed your last comment somehow. That issue generally happens when you don't add the unique ID to your Vanilla Comments code. Did you edit the code as indicated to include the post number?
This discussion has been closed.